wikiが壊れた・・・

2017/11/06

FuelPHPをインストしようとしたらPHPのバージョンが低いから・・・バージョンアップをすることに。

使っているサーバーがロリポップ。基本、放置的な感じなのでPHPのバージョンは5.2。
今回、「5.6」にアップデート。

5~10分待って諸々サイトの確認。

wordpressは管理画面にアクセスしても問題なし。ことあるごとにアップデートの告知が来て、アップデートをしていたので問題なかったっぽい。

MediaWiki・・・見た感じ異常を感じなかったので適当なページを更新すると書いていた内容が表示されなくなった。
他のページを見ると・・・触っていないページも内容が消えている・・・。
MediaWikiのバージョンアップを考えたけど・・・現状「1.18」っぽい。以前にもバージョンアップを考えたけど当時で「1.18からアップデートはタイヘン」ってのがあったので放置していたことを思い出した。
DBを見ると「テーブル:○○_page」の中が各ページっぽく、「カラム:page_restrictions」が内容っぽい。ただ「Blob型」で値は全部「[BLOB – 0 バイト]」となっている。

元に戻そうとしたけど、ロリポは「PHP5.2」のサポートは終わっているらしくダウングレードはできない。じゃぁDBだけでも・・・と思ったけどそもそもバックアップサービスは未加入・・・。

現状のMediaWikiのDBをエクスポートしてXamppにいれて確認しようかと思案中。
もしくは完全に諦めてまた、いちからコツコツとやっていこうかと思案中。

ひとまず「ラボ」にコツコツとやっていく予定。

新着(ニュース関連以外)

2017-11-09
PCでプッシュ通知ってのをしたい。
2017-11-06
PHPのバージョンを上げたらwikiが壊れたっぽい。
2017-08-03
formのinputでmaxlengthを使うとFirefoxでバグってた。他のブラウザでも気づかずにバグってたかもしれない。
2017-07-19
折れ線グラフをもう少しゆるやかに・・・というか何というか・・・調べていくと「移動平均」っていう言葉にたどり着いた
2017-07-10
FuelPHPの1.8をダウンロードして使っていたらセッションが使えないということに気付いた。